Wireshark spedisce un StartupItem
che fa proprio questo; tuttavia, l'API StartupItems è obsoleta:
The SystemStarter utility is deprecated. System services should instead
be described by a launchd.plist(5). See launchd(8) for more details.
The launchd utility is available on Mac OS X 10.4 and later.
In earlier versions of Mac OS X, the SystemStarter utility is used to
start, stop, and restart the system services which are described in the
/Library/StartupItems/ and /System/Library/StartupItems/ paths.
Quindi, dal momento che stai chiedendo "la soluzione più elegante", sarebbe un demone di lancio.
Non ho provato il seguente codice, ma dovrebbe essere approssimativamente corretto.
Crea un file /Library/LaunchDaemons/com.stackexchange.apple.bpf-helper.plist
:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>com.stackexchange.apple.bpf-helper</string>
<key>ProgramArguments</key>
<array>
<string>/Library/PrivilegedHelperTools/com.stackexchange.apple.bpf-helper.sh</string>
</array>
</dict>
</plist>
E un file /Library/PrivilegedHelperTools/com.stackexchange.apple.bpf-helper.sh
:
#!/bin/sh
chgrp admin /dev/bpf*
chmod g+rw /dev/bpf*
Entrambi dovrebbero essere di proprietà di root:wheel
. Il primo dovrebbe essere 644; il secondo 755 (600 e 700, rispettivamente, probabilmente faranno altrettanto).
Puoi utilizzare launchctl load -w /Library/LaunchDaemons/com.stackexchange.apple.bpf-helper.plist
per provarlo senza riavvio.