Come eseguire sshd sulla porta 500 in High Sierra?

1

Hanno cambiato le cose nelle versioni successive di macOS in modo che tu non possa semplicemente modificare etc/ssh/sshd_config come faresti con Linux. Cosa devo digitare nella shell per eseguire sshd sulla porta 500 anziché 22?

    
posta Walrus the Cat 05.12.2017 - 04:11
fonte

1 risposta

2

Per modificare la porta ssh, devi modificare il daemon di avvio ssh dell'host del server ssh:

  • disabilita SIP
  • apri ssh.plist:

    sudo nano /System/Library/LaunchDaemons/ssh.plist 
    
  • modifica <key>Sockets</key> (porta di esempio qui: 10022) da

        ...
        <key>Sockets</key>
        <dict>
                <key>Listeners</key>
                <dict>
                        <key>SockServiceName</key>
                        <string>ssh</string>
                        <key>Bonjour</key>
                        <array>
                                <string>ssh</string>
                                <string>sftp-ssh</string>
                        </array>
                </dict>
        </dict>
        ...
    

    a

        ...
        <key>Sockets</key>
        <dict>
                <key>Listeners</key>
                <dict>
                        <key>SockServiceName</key>
                        <string>10022</string>
                        <key>Bonjour</key>
                        <array>
                                <string>10022</string>
                                <string>10022</string>
                        </array>
                </dict>
        </dict>
        ...
    
  • scarica e carica il demone

    sudo launchctl unload /System/Library/LaunchDaemons/ssh.plist 
    sudo launchctl load /System/Library/LaunchDaemons/ssh.plist 
    
  • prova il demone ssh
  • abilita SIP

Un approccio alternativo e meno intrusivo consiste nel creare un secondo daemon di avvio ssh in / Library / LaunchDaemons /:

  • copia ssh.plist

    sudo cp /System/Library/LaunchDaemons/ssh.plist /Library/LaunchDaemons/ssh2.plist 
    
  • modifica ssh2.plist:

    sudo nano /Library/LaunchDaemons/ssh2.plist 
    

    cambia la chiave Etichetta in

    <key>Label</key>
    <string>com.openssh.sshd2</string>
    

    cambia la chiave <key>Sockets</key> come descritto in precedenza

  • disabilita SSH in Preferenze di Sistema > Condivisione > Login remoto
  • carica il daemon di avvio:

    sudo launchctl load -w /Library/LaunchDaemons/ssh2.plist 
    
  • con un rigoroso controllo dei tasti abilitato nel file di configurazione ssh su un host client ssh, potrebbe essere necessario rimuovere il server ssh dal file known_hosts di questo host remoto.
  • accedere al server ssh con ssh user@IP -p <port>
risposta data 27.01.2018 - 01:09
fonte

Leggi altre domande sui tag