Ho un'interfaccia C ++ per il fornitore di video. I frame possono essere ruotati (verticale / orizzontale) come risultato delle funzioni specifiche della piattaforma.
enum class EFrameOrientation
{
KUp, // default orientation
KDown,
KLeft,
KRight
};
Class fornisce all'utente informazioni sull'orientamento:
virtual EFrameOrientation getFrameOrientation() { return EFrameOrientation::KUp; }
Inoltre esegue il rendering dei frame che possiede con
virtual bool renderCurrentFrame() = 0;
virtual bool renderCurrentFrameWithOrientation() = 0; // STUB TO RENAME
e ho aggiunto una funzione che gestisce i problemi di orientamento, dando così a un utente già un frame con EFrameOrientation::KUp
-orientato.
L'orientamento non predefinito non è un bug, può essere desiderato in alcuni casi.
Tutti i nomi sottostanti mi sembrano semanticamente scorretti:
renderCurrentFrameRotated // doesn't say it's about orientation
renderCurrentFrameDefaultOriented // which orientation is default: KUp or current?
renderCurrentFrameOrientationFixed // its not bug to fix
Come sceglieresti un buon nome in questo caso?
Grazie in anticipo.