Primo esempio:
countryRepository.getCountriesFromAsiaWhereAreTheMostPlanesAndBoats();
countryRepository.getCountriesFromAfricaWhereAreTheMostCars();
Questi nomi sono troppo grandi? In quale altro modo chiamiamo queste funzioni?
Stavo pensando ai parametri, ma secondo Martin Fowler, è meglio non usare i parametri nelle funzioni.
Secondo esempio:
Devo usare queste due variabili nella classe:
public static class CompareCountries {
public String[] countriesFromAsiaWhereAreTheMostPlanesAndBoats;
public String[] countriesFromAfricaWhereAreTheMostCars;
public CompareCountries (String countriesFromAsiaWhereAreTheMostPlanesAndBoats, String[] countriesFromAfricaWhereAreTheMostCars){
this.countriesFromAsiaWhereAreTheMostPlanesAndBoats = countriesFromAsiaWhereAreTheMostPlanesAndBoats;
this.countriesFromAfricaWhereAreTheMostCars = countriesFromAfricaWhereAreTheMostCars;
}
public static String[] compares() {}
}
Qui più non posso usare i parametri.