I often see code that include intentional misspellings of common words that for better or worse have become reserved words:
klass or clazz for class: Class clazz = ThisClass.class
kount for count in SQL: count(*) AS kount
Personally I find this decreases readability. In my own practice I haven't found too many cases where a better name couldn't have been used — itemClass or recordTotal.
However, it's so common that I can't help but wonder if I'm the only one? Anyone have any advice or even better, quoted recommendations from well-respected programmers on this practice?
Per le variabili locali e gli argomenti formali, non ha importanza.
Qualsiasi nome va bene purché non sia intenzionalmente fuorviante o fastidioso da distrarre. Nel tuo esempio:
public static Method findBenchmarkMethod(BenchmarkRecord benchmark) {
Class<?> clazz = ClassUtils.loadClass(benchmark.generatedClass());
return findBenchmarkMethod(clazz, benchmark.generatedMethod());
}
non importa se la singola variabile locale è "clazz" o "klass" o "cls" o semplicemente "c". Probabilmente inserirò solo l'espressione:
return findBenchmarkMethod(ClassUtils.loadClass(benchmark.generatedClass()),
benchmark.generatedMethod());
La lunghezza di un nome di variabile dovrebbe essere correlata all'ambito della variabile. Per le variabili locali in metodi brevi (e dovrebbero essere tutte brevi), i nomi molto brevi vanno bene.