Disattiva permanentemente il Bluetooth

0

In che modo disattiva permanentemente il Bluetooth su OS X Mavericks? Sembra che semplicemente spegnendolo nelle preferenze non lo disabiliti.

    
posta username0 06.03.2014 - 09:37
fonte

1 risposta

3

Ho trovato un aspetto che rimuove i launchds & le estensioni del kernel per il bluetooth. Rende il sistema incapace di utilizzare le funzionalità Bluetooth:

#!/bin/bash

# disable bluetooth
# OS X 10.8.2
# 2012-10-08

home=$HOME
bk=$home/backup-bluetooth-extentions
mkdir $bk

# sudo reboot with Shift Key # Safty Boot
# Login as Admin usert.

#---------------------------------------------------------------------
# Local Backup OFF
#---------------------------------------------------------------------
# sudo tmutil disable
# sudo tmutil disablelocal

#---------------------------------------------------------------------
# Agnet
#---------------------------------------------------------------------
# bluetooth
launchctl unload -w /System/Library/LaunchAgents/com.apple.bluetoothUIServer.plist
launchctl unload -w /System/Library/LaunchAgents/com.apple.bluetoothAudioAgent.plist

#---------------------------------------------------------------------
# Daemon
#---------------------------------------------------------------------
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.blued.plist
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.bnepd.plist
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.IOBluetoothUSBDFU.plist

#---------------------------------------------------------------------
# Extentions
#---------------------------------------------------------------------
# Driver
sudo mv /System/Library/Extensions/AppleBluetoothMultitouch.kext $bk
sudo mv /System/Library/Extensions/IOBluetoothFamily.kext $bk
sudo mv /System/Library/Extensions/IOBluetoothHIDDriver.kext $bk

# Bluetooth Mouns & Keyboard
sudo mv /System/Library/Extensions/AppleHIDKeyboard.kext/Contents/PlugIns/AppleBluetoothHIDKeyboard.kext $bk
sudo mv /System/Library/Extensions/AppleHIDMouse.kext/Contents/PlugIns/AppleBluetoothHIDMouse.kext $bk

#---------------------------------------------------------------------
# touch
sudo touch /System/Library/Extensions

echo 'Shut Down & Restart'
    
risposta data 06.03.2014 - 09:42
fonte

Leggi altre domande sui tag